Boost failed updating targets

Could you please add some details to your question, ie is this Redhat Enterprise Linux and at least some versions. As you can see in the Primary Compiler List, there is no GCC 4.1.2.

Also, what is the newest version of GCC and Python you can install from Yum?

As such the minimum requirement to upgrade to Boost 1.58 is GCC 4.4.7.

boost failed updating targets-6

Please be aware that you must not upgrade GLIBC, or you may break your system. In file included from ../boost/filesystem/path_traits.hpp:23:0, from ../boost/filesystem/path.hpp:25, from ../boost/filesystem/operations.hpp:25, from regression/src/compiler_status.cpp:29: ../boost/system/error_code.hpp: At global scope: ../boost/system/error_code.hpp:2: warning: ‘boost::system::posix_category’ defined but not used [-Wunused-variable] static const error_category & posix_category = generic_category(); ^ ../boost/system/error_code.hpp:2: warning: ‘boost::system::errno_ecat’ defined but not used [-Wunused-variable] static const error_category & errno_ecat = generic_category(); ^ ../boost/system/error_code.hpp:2: warning: ‘boost::system::native_ecat’ defined but not used [-Wunused-variable] static const error_category & native_ecat = system_category(); ^ ...skipped compiler_status.o...gcc.archive ../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/libboost_program_options.a "/usr/x86_64-pc-linux-gnu/bin/ar" rc "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/libboost_program_options.a" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/cmdline.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/config_file.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/options_description.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/parsers.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/variables_map.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/value_semantic.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/positional_options.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/utf8_codecvt_facet.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/convert.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/winmain.o" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/split.o" "/usr/x86_64-pc-linux-gnu/bin/ranlib" "../bin.v2/libs/program_options/build/gcc-4.8/release/link-static/pch-off/threading-multi/libboost_program_options.a" ...failed updating 1 target...* ERROR: dev-libs/boost-1.55.0-r1::gentoo failed (compile phase): * Building of Boost tools failed * * Call stack: * ebuild.sh, line 93: Called src_compile * environment, line 3569: Called die * The specific snippet of code: * ejam ${OPTIONS}

* The ebuild environment file is located at '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/temp/environment'.* Working directory: '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/work/boost_1_55_0/tools' * S: '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/work/boost_1_55_0' '/mnt/video/tmp/portage/dev-libs/boost-1.55.0-r1/temp/build.log' * Messages for package dev-libs/boost-1.55.0-r1: * ERROR: dev-libs/boost-1.55.0-r1::gentoo failed (compile phase): * Building of Boost tools failed * * Call stack: * ebuild.sh, line 93: Called src_compile * environment, line 3569: Called die * The specific snippet of code: * ejam ${OPTIONS}